Yamaha Wolverine Forum banner

How is your FM radio reception in your rmax LTD?

  • My radio gets terrible FM reception, to none

    Votes: 36 81.8%
  • My radio picks up some channels

    Votes: 7 15.9%
  • My radio picks up all FM channels similar to my automobile

    Votes: 1 2.3%
121 - 140 of 153 Posts

·
Registered
2021 Rmax4 LE
Joined
·
52 Posts
It wont solve issue but may improve it some. Been there done that. Mine is disassembled so cant test now. (putting heater in ) but try shielding with metal/alum foil? between elect. unit boxes/amp. Might provide an improvement? I would but cant now.???? Or unplug elect connector?
 

·
Registered
2021 Rmax4 LE
Joined
·
52 Posts
I been playing around. I "think" I figured this out...Kinda. Wrap the bundle of wires including ant. leaving the amp unit under front hood. I wrapped it in layers of aluminum foil. This made a large improvement for me in fm reception. No doubt elect. interference is the issue. Not sure who is causing it. I played around but didnt find a smoking gun. I wrapped entire unit in foil and it worked however ya cant do this as heat will destroy it. Still working on this and I will notify SSV on Monday. Good luck and wrap your junk if ya want a good time...music that is!
 

·
Registered
2021 Red-neck Edition RMAX2 XT-R
Joined
·
551 Posts
I been playing around. I "think" I figured this out...Kinda. Wrap the bundle of wires including ant. leaving the amp unit under front hood. I wrapped it in layers of aluminum foil. This made a large improvement for me in fm reception. No doubt elect. interference is the issue. Not sure who is causing it. I played around but didnt find a smoking gun. I wrapped entire unit in foil and it worked however ya cant do this as heat will destroy it. Still working on this and I will notify SSV on Monday. Good luck and wrap your junk if ya want a good time...music that is!
Did you happen to disconnect the connections on the iQS unit which is located between the EPS unit and the SSV unit? That's my armchair quarterback guess.
 

·
Registered
2021 Rmax4 LE
Joined
·
52 Posts
Nope... Still putting her back together. Trying figure out how to wire led bar harness so its not "hot" as it is made that way... Think I will use Yamaha acc. plug under cowl to fire switch relay trigger instead of supplied hot always on wire to switch. I am cutting out cheap switch and replacing with a lit rocker and do not want it glowing when utv is off or worse my kids leave it on, again. Lol. Side note I RTV around defrost cowl as it leaks air.
 

·
Registered
Joined
·
12 Posts
It's kind of hard to grasp that it would only be on the LE models but from what i've learned reading this thread is those that put the system in on the XTR or base models are not having any issues.
2 members in this thread claim their xtr gets zero reception and once you add in myself that makes 3. There is also a thread from a 4th member who has a xtr with zero reception.

It may not be a issue on the base but its defiantly a issue on the xtr.

Have factory radio installed in xtr 1000-4. Terrible reception.
I bought the stereo and installed in my XTR. Same thing. Cannot get a radio station to come in.
 

·
Registered
Joined
·
183 Posts
2 members in this thread claim their xtr gets zero reception and once you add in myself that makes 3. There is also a thread from a 4th member who has a xtr with zero reception.

It may not be a issue on the base but its defiantly a issue on the xtr.
Thanks for posting as they are following this thread
 

·
Administrator
2021 RMAX4 LE
Joined
·
3,623 Posts
Taking the SSV stereo out of the vehicle and powering it up outside and using BT to stream to another device with speakers would confirm interference.
 

·
Registered
2017 Wolverine SE
Joined
·
4,155 Posts
Taking the SSV stereo out of the vehicle and powering it up outside and using BT to stream to another device with speakers would confirm interference.
True, but is it not easier to power off or remove/unplug the possible offending options which maybe generating EMI. There are standard for that adhered to by most manufacturers. Also engine off eliminates the engine components mostly anyway although the ECU is still powered. It should be the last item to do this though given the electrical engineering should meet all known specification EMI & RFI.

But as Massive says that would certainly prove something. If you have any other speakers to use temporarily its not to hard and a battery to power from.
 

·
Registered
Joined
·
114 Posts
My FM works fine for reception in the southern Arizona. Must be something else, why would some work and others not so much ?
 

·
Registered
Joined
·
183 Posts
My FM works fine for reception in the southern Arizona. Must be something else, why would some work and others not so much ?
Great question, you're the first person i've heard of with a LE that says the FM works fine.
 

·
Registered
Joined
·
114 Posts
Great question, you're the first person i've heard of with a LE that says the FM works fine.
I get 4+ stations and I live in the Tucson area. Doesn't sound like a high dollar stereo by any means but the stations come in just fine with out any help from a antenna.
Poll % numbers at the top of this post show 14.6 receive some stations.
 

·
Registered
2021 Rmax4 LE
Joined
·
52 Posts
It is interference. Unbolt unit/amp and wave around.... Reception improves. Wrap foil it improves. LE vs XTR was SSV trying decide if it was the IQS shock or Magellan causing issue. I think it is neither one. Canada models differ so confusion in XTR there for SSV. Bottom line a shield for AMP unit under hood is required. I am almost done with installs and I will be making shield. I will share my positve results and increased reception when done.
 

·
Registered
2021 RMAX 2 LE ..... 2021 X2 Rspec
Joined
·
43 Posts
I noticed when I ordered a crappy under hood mount antenna that if I held it up in the air I had good reception. It was a $7.00 dollar model so I did not want to mount it out from under the hood. I ordered this one from crutchfeild and will try it this weekend. If it works good I will mount it on the cowl like the ones on our cars and trucks. I will report back.
View attachment 97932
If you are mounting this in plastic, I "think" you will have to ground the base. Trying to remember my old CarFi installation days.. I could be wrong.
 

·
Registered
2017 Wolverine SE
Joined
·
4,155 Posts
Well battery ground should be tied to any shielding and case ground if there is any internally. If shielding is required is speaks to the design engineering. Which is Nil.
 

·
Registered
2021 RMAX 2 LE ..... 2021 X2 Rspec
Joined
·
43 Posts
Well ! I can't believe it! I have not fully installed it yet, but I bought the attached Metra Amplified antenna, and I GET RADIO STATIONS! I powered it, and set it on the roof, and viola! I have reception. This was something that SSV told me to order. I still think it is cruddy that you have to do this, but for 28$ to have a radio that works. I am very happy. Now to remove stock windshield support and hide wires.

 

·
Registered
2017 Wolverine SE
Joined
·
4,155 Posts
Wow, well the booster collects and drives a stronger signal correcting limitations in the SSV unit. They should be supplying it to all owners. Again this should not be a requirement in strong signal stations areas. Either the yamaha supplied antenna is not making connection or totally useless for some reason. You can poke a wire into the antenna port of any home stereo and pickup FM stations.
 

·
Registered
2021 RMAX 2 LE ..... 2021 X2 Rspec
Joined
·
43 Posts
Wow, well the booster collects and drives a stronger signal correcting limitations in the SSV unit. They should be supplying it to all owners. Again this should not be a requirement in strong signal stations areas. Either the yamaha supplied antenna is not making connection or totally useless for some reason. You can poke a wire into the antenna port of any home stereo and pickup FM stations.
You have my vote, and agreement. I wasted more energy and time on this than $28 could ever buy. I agree that it should work from the factory, but after more texts, calls, and emails to Yamaha, SSV, and the dealer, I think I have an acceptable outcome. I live in limited reception. I get about 6 stations in my car, and this gets 5 now ! IN THE GARAGE.. My wife's x2 Rspec only gets 3. So, may have to invest for that one too :)
 

·
Registered
2017 Wolverine SE
Joined
·
4,155 Posts
As I recall you were getting None or maybe one statioin. That indicates a problem when compared to your auto etc receivers.
 
121 - 140 of 153 Posts
Top