Yamaha Wolverine Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1 (Edited)
fuel pump isn't working

My wolverine isn't starting. I discovered that the fuel pump isn't working.

What could be the reasons why the fuel pump is not working?
Thank you.
 

·
Registered
Joined
·
65 Posts
Right by the batter there are two 10 amp fuses top one is fuel system. You can also download the service manual from fordtruckman and it has all the diagrams in there.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #5
Right by the batter there are two 10 amp fuses top one is fuel system. You can also download the service manual from fordtruckman and it has all the diagrams in there.
This fuse is working normally.
 

·
Registered
Joined
·
177 Posts
when you first turn on the ignition do you hear the fuel pump relay cycle (clicking sound) should hear it click then a couple seconds later click again it needs to prime the fuel rail but it wont stay active until engine is running.
if not I would try switching it with one of the other relays to see if you have a bad relay else you may have a fuel pump that went bad you would have to locate the connector for the fuel pump and check for juice when you cycle the key on also check the ground if those are good pump is probably bad.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #7 (Edited)
when you first turn on the ignition do you hear the fuel pump relay cycle (clicking sound) should hear it click then a couple seconds later click again it needs to prime the fuel rail but it wont stay active until engine is running.
if not I would try switching it with one of the other relays to see if you have a bad relay else you may have a fuel pump that went bad you would have to locate the connector for the fuel pump and check for juice when you cycle the key on also check the ground if those are good pump is probably bad.
Where is the fuel pump relay ?

I disconnected the fuel pipe attached to the fuel pump and when I cycled the key on, there was no fuel flow in the outlet pipe of the pump.
 

·
Registered
Joined
·
177 Posts
Under the hood there are two rows of them. I'm not at home right now but when I get there I'll look it up. If you want to get an answer faster the factory Yamaha service manual is available here on the forum to download for free I highly recommend you download it lots of good info there
 

·
Registered
Joined
·
177 Posts
The fuel pump relay is the center relay on the left side (passenger side closest to the fender) The one at the top of the right row closest to the firewall is the headlight relay I would try swapping around to test the relays.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #10
The fuel pump relay is the center relay on the left side (passenger side closest to the fender) The one at the top of the right row closest to the firewall is the headlight relay I would try swapping around to test the relays.
I checked the fuel pump relay and the fuse and they are working normally.

What the problem can be???
 

·
Registered
Joined
·
177 Posts
If you checked those items and you have power at the plug for the fuel pump by the fuel tank, then you have a bad fuel pump. Make sure you check the ground wires at the fuel pump connector as well.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #12
If you checked those items and you have power at the plug for the fuel pump by the fuel tank, then you have a bad fuel pump. Make sure you check the ground wires at the fuel pump connector as well.
I also checked all the connectors and the ground wires.
 

·
Registered
Joined
·
431 Posts
Run a hot wire and a ground directly to the fuel pump and it will tell you that it is good or bad. Keep the wires away fron the fuel in case it sparks.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #14
Run a hot wire and a ground directly to the fuel pump and it will tell you that it is good or bad. Keep the wires away fron the fuel in case it sparks.
The fuel pump connector has 4 pin of wires.
I guess two wires are of the fuel pump and the other two wires are of the fuel gauge.
Do you know who are the wires of the fuel pump ???
 

·
Registered
Joined
·
112 Posts
Discussion Starter #15
Where is the fuel filter?
 

·
Registered
Joined
·
112 Posts
Discussion Starter #16
???????????
 

·
Premium Member
Joined
·
433 Posts
Where is the fuel filter?
Went looking for the filter myself a while back, there isnt one shown on the parts diagram, I just assume it is in the pump assemble.
 

·
Registered
Joined
·
177 Posts
doesn't appear to use one accourding to the repair manual, but be cautious as this system should have 55 PSI. if wiring checks out replace the pump
 

·
Registered
Joined
·
112 Posts
Discussion Starter #19
doesn't appear to use one accourding to the repair manual, but be cautious as this system should have 55 PSI. if wiring checks out replace the pump
ok, thank you.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #20 (Edited)
20170725_171850[1].jpg 20170725_171844[1].jpg 20170725_171835[1].jpg 20170725_171801_HDR[1].jpg

This is my fuel pump.

I tried to connect the pump without the fuel filter to the fuel tank, and the pump still did not work.
I also connected the pump to 12v power supply, and the pump still did not work.

What the problem can be ????
 
1 - 20 of 33 Posts
Top