Yamaha Wolverine Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,047 Posts
Discussion Starter #1
was checking machine and found the bottom bolt on the fender extentsions was missing,other side also needed to be tightened.
 

·
Super Moderator
Joined
·
1,834 Posts
Dang it, haven't gotten mine put on yet. Those are aftermarket and put on by the dealer unless you have the Camo model.
 

·
Registered
Joined
·
575 Posts
I had a few bolts lose on my 2014 grizzly. Just the short ride on the trailer from the dealership to my job.. (5 minutes if you catch all the red lights) I had a bolt on the trailer and found it was for the front fender, the other side was lose. Later that day after I unloaded it, I found one of the 10mm that held on the front plastic skid plate, just under the front bumper had also fallen out... Never to be found..

I chalked it up the it being assembled at the dealership. Some tech probably fit the panels loose and overlooked them.. That was the only problem I had on my grizzly in the year that I owned it..

I haven't found a screw loose on the wolverine, I suspect that's because it's so new the tech doing finally assembly had to go by the book, and didn't get complacent as he'd likely assembled 100's of grizzly before.
 

·
Registered
Joined
·
1,047 Posts
Discussion Starter #4
Dang it, haven't gotten mine put on yet. Those are aftermarket and put on by the dealer unless you have the Camo model.
these are the front extentsions that are already on machine not the overfenders,I too am on the waiting list .
 
1 - 4 of 4 Posts
Top