Yamaha Wolverine Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
Today I got in some very thick deep mud. Had to use the winch to get out. Deep enough that when I was walking back to the Wolverine my right boot sunk in about 6 inches was like a mud vacuum. While trying to get out I manged to sink up to both knees. Had to get my friend to help pull be out. Mean while the Wolverine was still sinking. Tho we were able to winch it out. Still locked in 4 wheel drive. Going up a sandy semi muddy incline I kept hearing a loud clunk. Back on level ground the front left wheel just stopped. Power steering failed also. I took it completely out of 4 wheel drive. Drove it back to my truck, still with a slight clunking noise. We checked all the axles. Took it for a ride on the pavement and applied the brakes a few times. After that everything was working fine.

Thinking maybe something just got in the front left brake?
 

·
Super Moderator
Joined
·
1,834 Posts
There's some scrapers on the hub.. I bet you had a big rock or piece of wood stuck between it and the rim. Check the inside rim for gouges. Supposed to kick out rocks and stuff before it gets stuck on the caliper and damages the rim.
 

·
Registered
Joined
·
367 Posts
There's some scrapers on the hub.. I bet you had a big rock or piece of wood stuck between it and the rim. Check the inside rim for gouges. Supposed to kick out rocks and stuff before it gets stuck on the caliper and damages the rim.
If I read it right I believe he said it stopped when he took it out of 4x4
 

·
Registered
Joined
·
242 Posts
Discussion Starter · #5 ·
Was in full 4 wheel drive when it stopped. After washing it it I noticed the front disk brake was full of small rocks. Rode it again Sunday with no problems.
 
  • Like
Reactions: MORSNO
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top