Yamaha Wolverine Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
580 Posts
Discussion Starter #1
When I took possession of the Rmax, I didn't think anything of the engine functions on the screen all saying "N/A" on them, thinking it was a setup issue. All that worked was GPS speed, which is a native function of the tablet requiring no actual connection to the machine.

Well, now that I have set up, I've discovered there apparently is no power or connection to the dock. How I know this is that when you turn off the machine, or disconnect it from the dock, it should ask you if you want to shut down or stay on, that does not happen, not to mention no indication of charging when the machine is on. Also you can't change out any of the functions as stated in the manual. Beyond that, there is no wiring info on the dock at all, just a single cord that comes out of it that appears to go to the ECU.

So, I do the usual, checking all available fuses, finding all good, and have no idea where else to look for an issue. Also, the release button was very hard to release, having to push down very hard on it, then having to pull the tablet loose from it's catch. That can't be healthy for the tablet or the catch. So, after having to push so hard on the button to get it to release, the button has gone down into the dock and is not usable.

I will be at the dealers door first thing in the a.m. to demand another dock and adventure pro, or acceptable repair. Never fails, it's always going to be something, LOL...here's a pic unplugged from the dock, looks the same in the dock (when I could get it in...)

89152
 

·
Registered
Joined
·
654 Posts
That's a bummer. I'm sure they'll get you fixed up as quick as they can. Congrats on the new machine.
 
  • Like
Reactions: Lawur2

·
Registered
Joined
·
537 Posts
Is there a remote USB port. If so does it have power. The cable from the dock usually goes to the 12 volt to 5 volt electronics that provides the power needed by the dock and the remote port if there is one installed. They may have skipped that. The kits for the earlier vehicles all had that.
 

·
Registered
Joined
·
580 Posts
Discussion Starter #4
Is there a remote USB port. If so does it have power. The cable from the dock usually goes to the 12 volt to 5 volt electronics that provides the power needed by the dock and the remote port if there is one installed. They may have skipped that. The kits for the earlier vehicles all had that.
Hmm, good question, I'll look for that.
 

·
Premium Member
2020 X2-XTR
Joined
·
191 Posts
If the tablet comes on with the key, move on, it‘s not a power issue. Moot point as you are dealer bound. Edit. I just reread the OP, it’s power issue.
Minor glitch. Don’t let it rain on your parade!!!! CONGRATS!!
Harry
 
  • Like
Reactions: Jimbo

·
Premium Member
2020 X2-XTR
Joined
·
191 Posts
My cradle is on the grab bar. It is, and always has been, a bit tricky to get it off with it out in the open. If same cradle used, I can see some frustration ahead, for sure. There is a method of release where it just pops off easily, wish I could tell you exactly what that method is, however, I am still searching for it! For me, most of the time it comes off easily. Not true when I 1st installed it.
Good news is it never comes off on it’s own. Not even when you lay the buggy on its side as in my avatar!
Harry
 
  • Like
Reactions: therebel19

·
Registered
Joined
·
45 Posts
You have to use the Key to unlock the tablet from the dock before you push the release button. Not sure if you are aware of it because you didn't mention it.
 

·
Registered
Joined
·
10 Posts
When I took possession of the Rmax, I didn't think anything of the engine functions on the screen all saying "N/A" on them, thinking it was a setup issue. All that worked was GPS speed, which is a native function of the tablet requiring no actual connection to the machine.

Well, now that I have set up, I've discovered there apparently is no power or connection to the dock. How I know this is that when you turn off the machine, or disconnect it from the dock, it should ask you if you want to shut down or stay on, that does not happen, not to mention no indication of charging when the machine is on. Also you can't change out any of the functions as stated in the manual. Beyond that, there is no wiring info on the dock at all, just a single cord that comes out of it that appears to go to the ECU.

So, I do the usual, checking all available fuses, finding all good, and have no idea where else to look for an issue. Also, the release button was very hard to release, having to push down very hard on it, then having to pull the tablet loose from it's catch. That can't be healthy for the tablet or the catch. So, after having to push so hard on the button to get it to release, the button has gone down into the dock and is not usable.

I will be at the dealers door first thing in the a.m. to demand another dock and adventure pro, or acceptable repair. Never fails, it's always going to be something, LOL...here's a pic unplugged from the dock, looks the same in the dock (when I could get it in...)
Jimbo this sounds familiar! I was being walked through the new machine procedure when the tech and I had a problem releasing the Adventure Pro. After verifying the unit was in the keyed unlock position, I found the button had to be pressed down while wiggling the tablet fore/aft... Very tight tolerance here! Mine works, but not too confident now. I am curious how things go for you.
 

·
Registered
Joined
·
537 Posts
I sure hope it isn't the same dock setup as they have been using. You can bust one on a single first ride. I am on my 3rd cradle and if you don't modify them they won't last one day.
 

·
Premium Member
2020 X2-XTR
Joined
·
191 Posts
I sure hope it isn't the same dock setup as they have been using. You can bust one on a single first ride. I am on my 3rd cradle and if you don't modify them they won't last one day.
Do you have the RAM setup? That's what I have. It came in the kit. Mounted to the grab bar. Dont see how you could break that? Very robust.
Harry
 

·
Registered
Joined
·
580 Posts
Discussion Starter #12
Jimbo this sounds familiar! I was being walked through the new machine procedure when the tech and I had a problem releasing the Adventure Pro. After verifying the unit was in the keyed unlock position, I found the button had to be pressed down while wiggling the tablet fore/aft... Very tight tolerance here! Mine works, but not too confident now. I am curious how things go for you.
It was part user error part dock upper catch and button problem, it has to be perfectly aligned and rocked in from the bottom where there are little hooks, mine just wasn't making proper contact, and now functions normally. But my upper release button was VERY stiff, and wouldn't release the tablet unless you pulled pretty hard on it. I tried 2 at the dealership, and they came out easily. They are getting me a new dock or back plate. In the meantime, the magnets and outer door hold it in place just fine.
 

·
Registered
Joined
·
580 Posts
Discussion Starter #13
My cradle is on the grab bar. It is, and always has been, a bit tricky to get it off with it out in the open. If same cradle used, I can see some frustration ahead, for sure. There is a method of release where it just pops off easily, wish I could tell you exactly what that method is, however, I am still searching for it! For me, most of the time it comes off easily. Not true when I 1st installed it.
Good news is it never comes off on it’s own. Not even when you lay the buggy on its side as in my avatar!
Harry
Yah I'm petty sure it's the same cradle, they just designed the dash around it. Just have to be careful with the when new I guess, they are a little delicate in the upper latch system.
 

·
Registered
Joined
·
580 Posts
Discussion Starter #14
Jimbo this sounds familiar! I was being walked through the new machine procedure when the tech and I had a problem releasing the Adventure Pro. After verifying the unit was in the keyed unlock position, I found the button had to be pressed down while wiggling the tablet fore/aft... Very tight tolerance here! Mine works, but not too confident now. I am curious how things go for you.
Yah you also have to make sure the bottom is in properly and rocked in to the upper latch. Some are just tight I guess, and it's easy to not get a connection and it seems to be in.
 

·
Registered
Joined
·
537 Posts
Do you have the RAM setup? That's what I have. It came in the kit. Mounted to the grab bar. Dont see how you could break that? Very robust.
Harry
The cradle splits it two right down the middle and all the pussy ass little screws they used rip the little plastic nubs they screw into right off the plastic. If you don't disassemble and add screws all the way through in addition to epoxy gluing the perimeter it will fail.
Been through 3. First one made 2 outings, second one actually never made it to the trail. The whoops on 1/2 mile long path to the trail did it in.

Once modified they are better but not certain it won't happen again but been out a few times since putting the modified one in.
 

·
Registered
Joined
·
580 Posts
Discussion Starter #16
The Rmax ones are in dash,with a cover that holds them in place. Hopefully they won't have that issue.
 

·
Registered
Joined
·
36 Posts
Just curious what people use as a screen protector for the Adventure Pro? I used it last weekend while riding behind someone which got a little dusty and I scratched the piss out of the screen moving my finger around on the map. I am going to try some plastic polish on it and see if they will buff out-I'm assuming that it doesn't have a screen protector from the factory and that I actually scratched the screen(I don't have the machine here right now to investigate it further).
 

·
Registered
Joined
·
36 Posts
Checked it out-you are correct, I just scratched the plastic film protection-lol. If I take that off, do you recommend a screen protector or is it not really necessary?
 
1 - 20 of 22 Posts
Top