Yamaha Wolverine Forum banner
1 - 16 of 16 Posts

· Registered
21 Rmax4 XTR - SuperAtv Flip Windshield, JBS Fender Flares
Joined
·
14 Posts
Discussion Starter · #1 ·
I have a 21’ Rmax4 XTR with 4,000 miles on it and love every minute riding it.

Last weekend I was riding in WV and the machine would shut down whenever I would switch the 4wd. Happen from 2 wheel to 4 wheel and 4 wheel to 2 wheel. It cut off on me going down a hill coasting too. I noticed the yellow “check engine” light would come on after the engine turned off. I would have to turn the key off and crank it up. It would crank like normal.

I’m curious if this has happened to anyone else and if there is a fix I can do myself or take it to the dealership?

Other than terrible rear axles I haven’t had any issues for 4K miles.

Any suggestions or feedback would be much appreciated. Thank you in advance!
 

· Registered
21 Rmax4 XTR - SuperAtv Flip Windshield, JBS Fender Flares
Joined
·
14 Posts
Discussion Starter · #3 ·
That may possibly be it but the machine has turned off on me while coasting down a hill. I haven’t seen anyone else with this problem on the forum. Worst case I take it to dealership I have the extended warranty just don’t like being without my machine.
 

· Registered
21 Rmax4 XTR - SuperAtv Flip Windshield, JBS Fender Flares
Joined
·
14 Posts
Discussion Starter · #7 ·
Yes the light comes on like normal and the engine is around 190-200ish degrees. Really weird it cut off while I was coasting downhill too. I didn’t have the adventure pro the weekend or I would check to see if it was throwing a fault code. I’m going to try this weekend to see if I can repeat the problem. Hopefully the fault code will show up.
 

· Premium Member
Joined
·
1,176 Posts
When it shuts off does all of the dash / everything go out/off too? If some things are staying on, with key on power, when it shuts off, what are those things?
 
  • Like
Reactions: Paul65

· Registered
21 Rmax4 XTR - SuperAtv Flip Windshield, JBS Fender Flares
Joined
·
14 Posts
Discussion Starter · #9 ·
All lights on the dash stay on just the engine stalls. The “check engine” light comes on. I turn the key to off and it fires right back up. Weird….
 

· Registered
Joined
·
5,033 Posts
It's starting to sound like a weak fuel pump issue to me or a faulty tip over switch switch if is only happening when going down hill. There is also a huge amount of emissions stuff in front of the engine below the parking break. I had that get saturated when gas once on my X4 and it would cause cut out issues.
 

· Registered
21 Rmax4 XTR - SuperAtv Flip Windshield, JBS Fender Flares
Joined
·
14 Posts
Discussion Starter · #11 ·
I figure I would clean the air filter, check the spark plugs and check the spark arrestor this weekend. I’ve seen those arrestors clog up and make engines not idle right. Hopefully it’s one of those items and not something the dealer has to work on. I know I have several rides planned this year in WV and I don’t need a machine that stalls on me.
 

· Registered
Joined
·
166 Posts
It does not help your dilemma, but on several occasions my buggy had simply shut off when stationary idling. Every time it happens, it is at full temp just idling. Cranks up as normal and runs fine. Can't explain it. Does it one or two times per season and it is very intermittent.
 

· Registered
Joined
·
5,033 Posts
It does not help your dilemma, but on several occasions my buggy had simply shut off when stationary idling. Every time it happens, it is at full temp just idling. Cranks up as normal and runs fine. Can't explain it. Does it one or two times per season and it is very intermittent.
That's the new auto stop/start feature like newer vehicles have. :LOL:
 

· Registered
Joined
·
102 Posts
It does not help your dilemma, but on several occasions my buggy had simply shut off when stationary idling. Every time it happens, it is at full temp just idling. Cranks up as normal and runs fine. Can't explain it. Does it one or two times per season and it is very intermittent.
same here
 

· Rock Crawler
Joined
·
3,953 Posts
It does not help your dilemma, but on several occasions my buggy had simply shut off when stationary idling. Every time it happens, it is at full temp just idling. Cranks up as normal and runs fine. Can't explain it. Does it one or two times per season and it is very intermittent.
Glad to hear it’s not just me.
Asked my dealer about it and they said most everyone with an Rmax has mentioned it.
 

· Engineer
Joined
·
1,268 Posts
I think I remember that Yamaha lowers the throttle when shifting into four wheel mode. If for some reason you are already at a low throttle, I can see it shutting off the engine.
 
1 - 16 of 16 Posts
Top