Yamaha Wolverine Forum banner
1 - 20 of 35 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
I'll find out tomorrow hopefully. I was putting everything back together and installed my power commander from hunterworks ran it about 200 yards and now it sounds like a tribe of Indians in the motor. Now their is water in the oil too. Idk how it all happened I change my oil every 20 hours.
 

·
Registered
Joined
·
20 Posts
I'll find out tomorrow hopefully. I was putting everything back together and installed my power commander from hunterworks ran it about 200 yards and now it sounds like a tribe of Indians in the motor. Now their is water in the oil too. Idk how it all happened I change my oil every 20 hours.
Better hide that commander from the dealer.
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #6 ·
Yes it was all correct and idled fine in the garage for five mins before I rode it. The first thing I did was take it back out. I only have like 104 hours and just over 1000 miles and change my oil religiously.
 

·
Engineer
Joined
·
1,924 Posts
When you get it back, you might consider adding a few more intake tubes or larger diameter ones. Two 2" tubes does not even equal one 3" (not even considering length harmonics). The Rhino 700's used a 3" tube and it was very restrictive. You can use silicon tubes, they squash around tight areas, but still give you the cubic area needed. Two 3" silicon tubes, even squashed would be ideal. A=¶R²
 

·
Engineer
Joined
·
1,924 Posts
The factory 3" tube is very short, when you add length to it, you see a large drop in power. How big is the tube going to the plenum? 4-5"?
2" riser area = 3.14"²(2) = 6.28"². 3" riser area = 7.07"²(2) = 14.14"². I have a 3" ducted tube on my Rhino and in hindsight I wish I would have went to a 4" which would have given me 12.57"² instead of 7.07. :eek:

 

·
Registered
Joined
·
388 Posts
mine had some coolant in the oil but it was from a bad water pump seal or oil pump seal i dunno they replaced both, they said the culprit was a pinched drain line for the two seals so not sure if this is the same prob you are having or not.
 
1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top