ER-1 code even after new ECU....
Close
Login to Your Account
Yamaha Wolverine Forum

ER-1 code even after new ECU....

This is a discussion on ER-1 code even after new ECU.... within the Wolverine General Discussion forums, part of the Yamaha Wolverine Gen 1 708 cc SxS category; Hi folks, new to forum but not to working on atvs/UTvs . I’m a former Yamaha dealer from 97-2002. Just picked up a 2016 RSpec ...

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Like Tree4Likes

Thread: ER-1 code even after new ECU....

  1. #1
    Couch Potato Flambeau-5's Avatar
    Member #
    18284
    Join Date
    Jul 2020
    Posts
    8
    Member #
    18284

    ER-1 code even after new ECU....

    Hi folks, new to forum but not to working on atvs/UTvs . I’m a former Yamaha dealer from 97-2002.
    Just picked up a 2016 RSpec from friend who ran it low on oil/coolant.
    Just finished rebuild and now have ER-1 code on dash. Replaced ECU with used working version and new battery , still have no power or spark.....
    Old battery was showing 16 volts so I figured it shorted out ECU
    900 miles, anyone have idea on where to start ?
    Fuses good, ground solid
    Need some pointers !!!

  2. #2
    Ripsaw jimclemjr's Avatar
    Member #
    8794
    Join Date
    Jun 2017
    Location
    Nashville
    Posts
    1,324
    Member #
    8794
    Liked
    1166 times
    please describe succinctly "no power", and what you have done to check main fuse or cables.
    Did the main ground cable on front of motor get remembered?
    Last edited by jimclemjr; 07-25-2020 at 12:18 AM.
    blast likes this.
    2016 Wolverine R-spec EPS- Black , JBS CVT grind, 16 gr OD, Purple, slugs, JBS rad guards, Autometer Temp Gauge, Alba Racing Reflash, SATV A-arms & DIY stick guards, Flip wshield, Auto tie rod ends, Dual batts/man switch, ALS defeat, Method 14" B-locks, YXZ wheel studs, 28" 9 & 11 BH 2.0, 4000# Moto Max winch, Yama trunk, Rigid D pods on bumper, 3"rear cage lower, JBS/Eibach springs, SPAL fan, ACM doors, Lexan moonroof, Pyle rear cam, Midland MXT275

  3. #3
    Lightning kdt1970's Avatar
    Member #
    10002
    Join Date
    Sep 2017
    Location
    Grantsville, Utah
    Posts
    776
    Member #
    10002
    Liked
    557 times
    Hopefully this helps.
    Name:  15956820131279032387902169909794_1595682072071.jpg
Views: 29
Size:  759.7 KB
    jimclemjr likes this.
    2017 Wolverine R-Spec SE
    2019 Wolverine X4

    2017 Super Atv - Front Window
    2017 Kolpin - Rear Window
    2017 Kolpin - Side Mirrors
    2017 Ryco - Utah Street Legal Kit
    2017 Yamaha - LED taillights with Reverse
    2017 Hunterworks - AIS Block Off Plate
    2017 NGK - Laser Iridium spark plug
    2019 Yamaha - Windshield
    2019 Yamaha - Rear View Mirror
    2019 Yamaha - Roof
    2019 Emp - Side Mirrors
    2019 SuperAtv - Rear Window.
    2019 Ryco - Utah Street Legal Kit
    2019 NGK - Laser Iridium spark plugs

  4. Remove Advertisements
    WolverineForums.com
    Advertisements
     

  5. #4
    Couch Potato Flambeau-5's Avatar
    Member #
    18284
    Join Date
    Jul 2020
    Posts
    8
    Member #
    18284
    Ground wire removed cleaned and tight, main 40amp fuses check out
    Working on meter connections now

  6. #5
    Ripsaw jimclemjr's Avatar
    Member #
    8794
    Join Date
    Jun 2017
    Location
    Nashville
    Posts
    1,324
    Member #
    8794
    Liked
    1166 times
    do not rely on visual fuse check. run some power thru the big ones
    2016 Wolverine R-spec EPS- Black , JBS CVT grind, 16 gr OD, Purple, slugs, JBS rad guards, Autometer Temp Gauge, Alba Racing Reflash, SATV A-arms & DIY stick guards, Flip wshield, Auto tie rod ends, Dual batts/man switch, ALS defeat, Method 14" B-locks, YXZ wheel studs, 28" 9 & 11 BH 2.0, 4000# Moto Max winch, Yama trunk, Rigid D pods on bumper, 3"rear cage lower, JBS/Eibach springs, SPAL fan, ACM doors, Lexan moonroof, Pyle rear cam, Midland MXT275

  7. #6
    Mountaineer
    Member #
    15468
    Join Date
    Mar 2019
    Location
    SE WI.
    Posts
    313
    Member #
    15468
    Liked
    218 times
    No lights ? Never heard of a 12 volt battery with 16 volts? Is the voltage regulator in the ECU? On the older Rhino's when my AC generator burned up(2x) because of heat, you could disconnect the rectifier and run on the battery. No idea . Good luck!
    2019 X2 R-spec SE, Black, Full cab, heater, wiper, tracks, Warn 4500 wireless winch,synthetic. Sendona wheels, 5/2, Sedona rip saws 27x11xR14 , Moose plow, Furion RV back-up camera, Garmin GPS. All Glass.

  8. #7
    Couch Potato Flambeau-5's Avatar
    Member #
    18284
    Join Date
    Jul 2020
    Posts
    8
    Member #
    18284
    Both large 40amp fuses will transfer power fine, motor spins over , just no spark or power to fuel
    Pump

  9. #8
    Supporting Member
    Member #
    241
    Join Date
    Jun 2015
    Location
    TN
    Posts
    793
    Member #
    241
    Liked
    816 times
    I suspect you may have already done part of this, but for the sake of troubleshooting I'll suggest it anyway.

    If everything else except for the fuel pump seems to have power (dash, headlights, etc.) then I would first check fuel pump fuse, and then check all connections going in to and coming out of the fuel pump relay for 12v and a good ground, if that all checks out good then you know the problem is between the relay and fuel pump or between fuel pump and ground. Connect 12v directly to the fuel pump to verify the fuel pump will cycle on, can do with jumper wiring with key off.
    TN_Max and blast like this.
    2016 R Spec EPS, Realtree, 29x9x14 & 29x11x14 Tusk Warthogs on ITP SS112
    Hunterworks Sheave, Greaseless 18 gr wts (did have 16 gr.), Purple Sec. Spring, Wet Clutch Slugs, CVT Blow Out Port
    Painted Control/Gear Symbols, Bad Dog Side Mirrors, EMP Panoramic Rear Mirror,
    Interior Overhead LED lights, Blue Floorboard LED Lights, Custom Side Rain Curtains
    Radiator Mud Guards, Yamaha Alum. Front Diff. Guard, Perfex 2" Lift, Winch,
    Grease Fitting Modification for Lower Rear A-Arm, Koso Coolant Temp. Gauge,
    RAM Mounts for GPS & 8" Tablet, Under Seat Storage Box, Folding Windshield,
    EMP Front/ Rear Bumpers, 100W 17" LED light, 18W Rear Flood LEDs 2x,
    60W Front Cubes Pillar Mounted, Great Day Gun Rack, Stebel Air Horn,
    Adjustable Driver's Seat, Turn Signals, Street Legal/TN Tag, Midland MXT115 Radio,
    Custom Bed Overhead Storage Carrier

  10. #9
    Couch Potato Flambeau-5's Avatar
    Member #
    18284
    Join Date
    Jul 2020
    Posts
    8
    Member #
    18284
    I still don’t have any spark

  11. #10
    Ripsaw jimclemjr's Avatar
    Member #
    8794
    Join Date
    Jun 2017
    Location
    Nashville
    Posts
    1,324
    Member #
    8794
    Liked
    1166 times
    I'm pretty sure you have an IGN fuse- Checked?
    2016 Wolverine R-spec EPS- Black , JBS CVT grind, 16 gr OD, Purple, slugs, JBS rad guards, Autometer Temp Gauge, Alba Racing Reflash, SATV A-arms & DIY stick guards, Flip wshield, Auto tie rod ends, Dual batts/man switch, ALS defeat, Method 14" B-locks, YXZ wheel studs, 28" 9 & 11 BH 2.0, 4000# Moto Max winch, Yama trunk, Rigid D pods on bumper, 3"rear cage lower, JBS/Eibach springs, SPAL fan, ACM doors, Lexan moonroof, Pyle rear cam, Midland MXT275

Page 1 of 2 1 2 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
WolverineForums.com is an independent Yamaha enthusiast website. Content on WolverineForums.com is generated by its users and WolverineForums.com is not in any way affiliated with Yamaha Motor Corporation, U.S.A.