Did some thing stupid need help
Close
Login to Your Account
Yamaha Wolverine Forum

Did some thing stupid need help

This is a discussion on Did some thing stupid need help within the Wolverine General Discussion forums, part of the Yamaha Wolverine Gen 1 708 cc SxS category; I purchased a wrecked 2016 especially and I heard it run a couple weeks buy jumping it ago so I went back today to pick ...

Results 1 to 8 of 8

Thread: Did some thing stupid need help

  1. #1
    Spectator
    Member #
    15320
    Join Date
    Jan 2019
    Posts
    4
    Member #
    15320
    Liked
    3 times

    Did some thing stupid need help

    I purchased a wrecked 2016 especially and I heard it run a couple weeks buy jumping it ago so I went back today to pick it up and took my big battery charger while bsing I hooked it up backwards polarity now I don’t have nothing at all no lights anywhere ,will not crank or anything
    What Damage did I do by reverse polarity ;is there a fuse or relay that I fried or what do I start looking for I need help I don’t have a service book yet one is on order

  2. #2
    Experienced jimclemjr's Avatar
    Member #
    8794
    Join Date
    Jun 2017
    Location
    Nashville
    Posts
    505
    Member #
    8794
    Liked
    309 times
    You can search this site and download the manual. I would first of all guess you fried the regulator but before I jumped to that conclusion I would install a properly charged battery in it to see what you get. If nothing check the main fuse and the ground wire to the frame to see if it melted in-two. Since the unit was wrecked there is a chance that some crucial wires are broken or grounds separated so verify those basics first. When you install the battery and hook it up the first time, install ground cable first and then before you put on positive cable use a voltmeter to see if there is any draw to alert you to a parasitic drain.
    2016 Wolverine R-spec EPS- Camo, , JBS CVT grind, 16 gr OD, Purple, slugs, JBS mudguards, Autometer Temp Gauge, OEM stickguards, Flip wshield, Auto tie rod ends, Dual batts/manual switch, ALS defeat, Method 14" B-locks, 27" 9 & 11Maxxis Vipr,4000 Moto Max winch, Yama trunk, 20" single row roof light bar, Rigid D pods on bumper, 3"rear cage lower, harness bar and 4 pt harnesses, JBS/Eibach springs

  3. #3
    Spectator
    Member #
    15320
    Join Date
    Jan 2019
    Posts
    4
    Member #
    15320
    Liked
    3 times

    Did some thing stupid need help

    Will grab a new battery this weekend what battery is every one running in these? Almost looks like a small tractor battery but don’t know the cca of the factory battery any input

  4. Remove Advertisements
    WolverineForums.com
    Advertisements
     

  5. #4
    Gear Grinder Ken Scurry's Avatar
    Member #
    15102
    Join Date
    Dec 2018
    Location
    Brooks, Georgia
    Posts
    202
    Member #
    15102
    Liked
    131 times
    Set up a “Go Fund Me” Account and see if these fine members will help you get a 2019 modal.
    2019 Camo X2 with a bunch of junk I probably don’t need!

  6. #5
    Mountaineer Jimbo's Avatar
    Member #
    13554
    Join Date
    May 2018
    Location
    Emmett, Idaho
    Posts
    263
    Member #
    13554
    Liked
    263 times
    Hey, now there's an idea!
    2017 Wolverine R-Spec EPS, Alpine white

    Super ATV full flip windshield~Yamaha soft doors & Rear window~KFI 3000# winch & mount~Overhead gun rack~Tablet GPS
    Apeman video cam~Rear bench seat and integrated storage box~Monster Nomad blue tooth speaker~Perfex 2" lift
    Yamaha padding kit~Accessory bar~Overfenders~Sedona Ripsaw R/T 28x10R14 tires on Storm beadlock wheels ~Chupacabra side mirrors~AIS block off~X4 SE red, black, grey seats~X4 SE steering wheel~Traveller LED's

  7. #6
    Lead Super Moderator MORSNO's Avatar
    Member #
    465
    Join Date
    Oct 2015
    Location
    Eagle River, Alaska
    Posts
    3,134
    Member #
    465
    Liked
    1341 times
    You can download a free pdf copy of the factory service manual from the signature block of forum member Tinken.
    2016 Alpine White Wolverine R-Spec SE
    27" Tusk Terrabites, 2" Gorilla lift kit, Over Fenders, Warn 3500 Winch, Folding Windshield, Rear Windscreen, Accessory Bar & Gun Mount, Front & Rear Grab Bar Bumpers, Cargo Bed Box, Rear-view Mirror, RAM GPS Mount, Battery Tender Charger, Seizmik Pursuit Mirrors, Lux-Pro Dome Light, Throttle Maxx Pedal Extension, Yamaha Aluminum Front Skid Plate, TGM Off-Road/Konstruktor Doors W/White & Gray Decals

  8. #7
    Sparky
    Member #
    8129
    Join Date
    Apr 2017
    Location
    Ne ohio
    Posts
    626
    Member #
    8129
    Liked
    342 times
    Try a new battery and check your fuses. I kind of doubt you wouldve fried the harness.
    2016 green R-Spec, oem folding front shield , front and rear lighting, 27x9 & 27x11 Kenda Bearclaw HTR, Warn 4500 Provantage, KFI plow set up, Custom bash plate, Hunterworks PCV and AIS blockoff, Hunterworks exhaust tip (modified with partial stock baffle)

  9. #8
    Sunday Driver
    Member #
    15496
    Join Date
    Mar 2019
    Location
    SE Pa
    Posts
    49
    Member #
    15496
    Liked
    61 times
    Nah, no fried harness from reverse polarity.
    But, I've heard of fried ecm's and other electronics.
    But start with the basics.
    Good luck.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Need some help..
    By Island boy in forum Wolverine X2/X4 General Discussion
    Replies: 0
    Last Post: 02-11-2019, 01:22 PM
  2. Blown Shock - Need some help
    By Sierra in forum Wolverine General Discussion
    Replies: 0
    Last Post: 10-29-2017, 07:07 PM
  3. Bent lower A arm - Need some help
    By Sierra in forum Wolverine General Discussion
    Replies: 10
    Last Post: 01-21-2017, 06:34 PM
  4. need some help with a ten plug switch for winch
    By Okiecat in forum Audio, Lighting and Electrical
    Replies: 3
    Last Post: 12-24-2016, 07:46 PM
  5. Need some help/input
    By Wi_Rider in forum Engine
    Replies: 34
    Last Post: 03-20-2016, 07:52 PM
WolverineForums.com is an independent Yamaha enthusiast website. Content on WolverineForums.com is generated by its users and WolverineForums.com is not in any way affiliated with Yamaha Motor Corporation, U.S.A.