Towed home Friday night - Page 5
Close
Login to Your Account
Yamaha Wolverine Forum

Towed home Friday night

This is a discussion on Towed home Friday night within the Wolverine General Discussion forums, part of the Yamaha Wolverine Gen 1 708 cc SxS category; Fuel system and tank has been cleaned and serviced. Looking at a rzr 900s or maverick 1000. X2 was very quiet, but the 50 mph ...

Page 5 of 5 FirstFirst ... 3 4 5
Results 41 to 50 of 50
Like Tree41Likes

Thread: Towed home Friday night

  1. #41
    Pit Stop
    Member #
    7705
    Join Date
    Mar 2017
    Posts
    94
    Member #
    7705
    Liked
    59 times
    Fuel system and tank has been cleaned and serviced. Looking at a rzr 900s or maverick 1000. X2 was very quiet, but the 50 mph speed limiter just stinks.

    Jim
    2019 Can am maverick sport 1000R
    Lots of goodies

    2016 R-spec eps (sold)
    3500 lbs Superwinch
    KFI mounting plate
    20" light bar
    2 Pillar mount Rigid dully d2s
    2" Super atv lift
    Super atv flip up windshield
    27” Tusk Terrabites
    Yeti cooler copy
    Beer

  2. #42
    Silver Bullet
    Member #
    15104
    Join Date
    Dec 2018
    Posts
    707
    Member #
    15104
    Liked
    219 times
    I looked back as saw what was checked and doesn't look like the fuel sensor was replaced. But given what was checked and what could also be responsible. I'd push to have them replace the fuel pump. They can be erratic and certainly sound like a fuel issue. The backfiring cause is odd, but there could be a condition where that may happen due to a failing pump. I certain doesn't appear to be mechanical. Since its not doing it all the time certain parts should be changed out.

    Good Luck!!!
    2017 Wolverine RSPec SE
    Belleville, Ont. Canada

    BigHorn 2.0 27 inch tires
    Half windshield
    Roof
    Aluminum Under armor
    Yamaha Warn 3500lb Winch & Synthetic rope

  3. #43
    Veteran
    Member #
    539
    Join Date
    Nov 2015
    Location
    Cuyahoga Falls, Ohio
    Posts
    466
    Member #
    539
    Liked
    163 times
    Bringing this thread back to the top for reference to my problem/thread under "engine" section. So Jim is this now running correctly?

  4. Remove Advertisements
    WolverineForums.com
    Advertisements
     

  5. #44
    Pit Stop
    Member #
    7705
    Join Date
    Mar 2017
    Posts
    94
    Member #
    7705
    Liked
    59 times
    Leadsled, It is not running correctly. Ran great for a few rides. Last week it kept stalling and had significant power loss. Turned it off and restarted about 30 minutes later and it ran fine and has been since. Actually trading it in this weekend and put a deposit on a can am maverick sport 1000r. Moving over to the dark side. I have had Yamaha’s for many years and considered the x2, but the speed governor and the better dealer in my area closed up shop. I have a can am dealer 15 minutes away and they offer great service.

    Jim
    MORSNO likes this.
    2019 Can am maverick sport 1000R
    Lots of goodies

    2016 R-spec eps (sold)
    3500 lbs Superwinch
    KFI mounting plate
    20" light bar
    2 Pillar mount Rigid dully d2s
    2" Super atv lift
    Super atv flip up windshield
    27” Tusk Terrabites
    Yeti cooler copy
    Beer

  6. #45
    Silver Bullet
    Member #
    15104
    Join Date
    Dec 2018
    Posts
    707
    Member #
    15104
    Liked
    219 times
    Out of curiosity do you have the PC5 on that 2016?

    If you did have the Power Commander 5 controller and if it was working properly. Removing it should not be required but from what I have read. Nothing is specified to determine that it is.
    Last edited by Tripplec; 04-27-2019 at 07:44 AM.
    2017 Wolverine RSPec SE
    Belleville, Ont. Canada

    BigHorn 2.0 27 inch tires
    Half windshield
    Roof
    Aluminum Under armor
    Yamaha Warn 3500lb Winch & Synthetic rope

  7. #46
    Pit Stop
    Member #
    7705
    Join Date
    Mar 2017
    Posts
    94
    Member #
    7705
    Liked
    59 times
    No pc5 on the machine
    2019 Can am maverick sport 1000R
    Lots of goodies

    2016 R-spec eps (sold)
    3500 lbs Superwinch
    KFI mounting plate
    20" light bar
    2 Pillar mount Rigid dully d2s
    2" Super atv lift
    Super atv flip up windshield
    27” Tusk Terrabites
    Yeti cooler copy
    Beer

  8. #47
    Veteran
    Member #
    539
    Join Date
    Nov 2015
    Location
    Cuyahoga Falls, Ohio
    Posts
    466
    Member #
    539
    Liked
    163 times
    Jim I just fixed my wolverine. It was dirt in the injector. I removed injector , inspected it but could not see anything wrong. I sprayed it with carb cleaner and reinstalled it in the fuel rail and tried to start it which confirmed the spray pattern was good. Reinstalled the fuel rail and injector to engine and it runs great now.

  9. #48
    Pit Stop
    Member #
    7705
    Join Date
    Mar 2017
    Posts
    94
    Member #
    7705
    Liked
    59 times
    I cleaned the fuel tank and injector. The dealer did the same also. They also checked the fuel pressure and tried a new fuel pump. Jim
    2019 Can am maverick sport 1000R
    Lots of goodies

    2016 R-spec eps (sold)
    3500 lbs Superwinch
    KFI mounting plate
    20" light bar
    2 Pillar mount Rigid dully d2s
    2" Super atv lift
    Super atv flip up windshield
    27” Tusk Terrabites
    Yeti cooler copy
    Beer

  10. #49
    Evil Kenevil erik's Avatar
    Member #
    10745
    Join Date
    Oct 2017
    Location
    ON, CANADA
    Posts
    436
    Member #
    10745
    Liked
    319 times
    The fact that you never quite got this resolved bothers me... I do know it certainly wasn't for a lack of trying!

    It's something that is now in the back of my mind!

    Anyhow thanks for posting and letting us know, hope you enjoy your new ride.

    Cheers
    2017 Wolverine R-Spec Blue
    2008 B-King
    1997 KLR650

  11. #50
    Silver Bullet
    Member #
    15104
    Join Date
    Dec 2018
    Posts
    707
    Member #
    15104
    Liked
    219 times
    Yeah, I too am concerned with mine which is new. Given it ran long enough to get out before quitting. The dealer should have replace some key parts even though the seemed ok. Since something was failing after time. Fuel pump would have been a good candidate IMO then some other parts if not a thermal issue.

    Fuel Pump Relay also could have bad contacts after some running time. This is an easy swap out or switch with an alternate relay if they're the same (likely are as long as it isn't a critical circuit)
    Last edited by Tripplec; 05-02-2019 at 08:21 AM.
    2017 Wolverine RSPec SE
    Belleville, Ont. Canada

    BigHorn 2.0 27 inch tires
    Half windshield
    Roof
    Aluminum Under armor
    Yamaha Warn 3500lb Winch & Synthetic rope

Page 5 of 5 FirstFirst ... 3 4 5

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. towed home today
    By trailcutter in forum Wolverine General Discussion
    Replies: 31
    Last Post: 04-14-2017, 08:03 AM
  2. Took my Wolverine out for a Moonlight ride last night
    By 650pilot in forum Wolverine Pictures / Videos
    Replies: 3
    Last Post: 03-21-2017, 10:13 PM
  3. A short night ride video in the Wolvy
    By ky kodiak in forum Wolverine Pictures / Videos
    Replies: 3
    Last Post: 11-19-2016, 06:06 PM
  4. wednesday night ride in vermont
    By VTpoolman in forum Wolverine General Discussion
    Replies: 7
    Last Post: 07-07-2016, 07:25 AM
  5. Night Riding
    By Wi_Rider in forum Wolverine Pictures / Videos
    Replies: 8
    Last Post: 09-14-2015, 05:30 AM
WolverineForums.com is an independent Yamaha enthusiast website. Content on WolverineForums.com is generated by its users and WolverineForums.com is not in any way affiliated with Yamaha Motor Corporation, U.S.A.